AWS portal impairment.

Incident Report for White Label Communications LLC

Resolved

AWS has noted this incident as resolved.
Posted Oct 20, 2025 - 20:20 EDT

Monitoring

AWS has implemented a fix and they are observing normal network traffic at this point. We will continue to monitor.
Posted Oct 20, 2025 - 18:04 EDT

Identified

We are currently aware of an incident in AWS causing degraded portal performance. AWS is working to correct their issues.
Posted Oct 20, 2025 - 11:04 EDT
This incident affected: Apps (Web Portal).