Call completion failures and degradation

Incident Report for White Label Communications LLC

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 18:44 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2026 - 07:59 EDT

Update

We are continuing to investigate the underlying issue. At this time, services appear to be stable.
Posted Mar 12, 2026 - 20:12 EDT

Identified

We have isolated the incident, and we are working towards a fix.
Posted Mar 12, 2026 - 17:53 EDT

Investigating

We are currently investigating issues in one of our data centers. The engineering team is actively investigating. We will provide any updates as they become available.
Posted Mar 12, 2026 - 16:54 EDT
This incident affected: Inbound Calling and Outbound Calling.