Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 08, 2026 - 23:00 EDT
Scheduled
We will be performing planned infrastructure maintenance in our Philadelphia data center as part of a network modernization effort. This work includes replacing core networking, routing, and firewall components that support services in the Philadelphia site.
During the maintenance window, we plan to temporarily remove the Philadelphia application zone from active service to reduce the risk of partial or inconsistent service behavior while network changes are completed. Services are expected to continue operating from our other available data center zones during this period.
Properly configured endpoints and customer systems should automatically fail over to alternate available zones. Some customers may notice brief registration changes, routing changes, or temporary service interruptions while failover occurs or while systems are validated following the network transition.
After the network work is completed, our team will perform service validation and gradually return Philadelphia services to normal operation once testing confirms stability.
Posted May 02, 2026 - 09:00 EDT
This scheduled maintenance affected: Data Centers Regions (East) and Registration, Inbound Calling, Outbound Calling, Call Center, Fax.