Issues with Atlas web portal email delivery
Incident Report for White Label Communications LLC
Resolved
This incident has been resolved.
Posted Feb 14, 2024 - 09:57 EST
Monitoring
Mailgun has stated that a mitigation is in place for the email delivery issues, all impacts of the attack have been mitigated at this time. We are continuing to monitor.
Posted Feb 13, 2024 - 09:05 EST
Identified
We have confirmed with our third-party email partner Mailgun that they are currently experiencing a DDoS attack and are working to mitigate the attack. This integration is essential to our outbound email communication from Atlas to our partners and end-users. As a precaution, we have intentionally halted invoice processing to avoid inconsistent delivery of those communications. As soon as the issue is resolved, we will resume normal billing operations and notifications will be dispatched accordingly.

For status updates on mailgun, see: https://status.mailgun.com
Posted Feb 12, 2024 - 13:08 EST
Investigating
We are currently investigating an issue with email delivery from the Atlas portal. We are aware of an issue with our downstream provider and are pursuing the issue with their team.
Posted Feb 12, 2024 - 09:35 EST
This incident affected: Apps (Email Delivery).